clock menu more-arrow no yes

Filed under:

Metro: Last Light system requirements available, game bundled with Nvidia GTX 660 and up

New, 11 comments

If you buy something from a Polygon link, Vox Media may earn a commission. See our ethics statement.

Metro: Last Light developer 4A Games is building a game that will push your PC to its limits, and the company teamed up with Nvidia today to release three sets of system requirements for the upcoming shooter.

The game will take advantage of Nvidia technology including PhysX to deliver advanced visual effects and a great-looking game, the graphics card manufacturer said on the GeForce blog. Nvidia posted minimum, recommended and optimum system requirements for Metro: Last Light; you can check them out at the bottom of this article. They're more detailed than the specifications in the game's Steam listing.

Nvidia is including a free Steam copy of Metro: Last Light with GeForce GTX 660 and above graphics cards. Participating retailers in North America include Amazon and TigerDirect.

Metro: Last Light will be released May 14 on Windows PC, Xbox 360 and PlayStation 3.

Minimum System Requirements
Windows: XP (32-Bit), Vista, 7 or 8
CPU: 2.2 GHz Dual Core e.g. Intel Core 2 Duo
RAM: 2 GB
Direct X: 9.0c
Graphics Card: DirectX 9, Shader Model 3 compliant, e.g. Nvidia GTS 250 or higher

For 3D Vision Support:
Nvidia GTX 275 or higher
120Hz 3D Vision Monitor
Nvidia 3D Vision kit for Windows Vista, 7 or 8

Recommended System Requirements
Windows: Vista, 7 or 8
CPU: 2.6 GHz Quad Core, e.g. Intel Core i5
RAM: 4 GB
Direct X: 11
Graphics Card: Nvidia GTX 580 / 660 Ti or higher

For 3D Vision Support:
Nvidia GTX 580 / 660Ti or higher
120Hz 3D Vision Monitor
Nvidia 3D Vision kit for Windows Vista, 7 or 8

Optimum System Requirements
Windows: Vista, 7 or 8
CPU: 3.4 GHz Multi-Core, e.g. Intel Core i7
RAM: 8 GB
Direct X: 11
Graphics Card: Nvidia GTX 680 SLI / Nvidia GTX 690 / Nvidia Titan

For 3D Vision Support:
Nvidia GTX 680 SLI / Nvidia GTX 690
120Hz 3D Vision Monitor
Nvidia 3D Vision kit for Windows Vista, 7 or 8